CommonSpot Supported Browsers

browsersCommonSpot’s content management interface is entirely browser-based; there is no need to install or maintain client software. Pages are viewable from most standard browsers including Chrome, Safari, Microsoft Internet Explorer, and Mozilla-based browsers.

You must use one of the supported web browsers to author in CommonSpot. Functionality and performance may be affected otherwise. Seton Hall is currently running CommonSpot “Summer 2012″ (version 8).

Authoring Browser Requirements

  • Internet Explorer 8, 9 and 10 (Windows)
  • Firefox 10 ESR and Firefox 17 ESR version (Windows, Linux, Mac). (Mozilla has stopped patching Firefox 10, so it is no longer safe for general browsing; it is safe for authoring on CommonSpot. 17 ESR has security enhancements that limit Cut, Copy and Paste options.)
  • Chrome 24 and 25 (Windows, Linux, Mac) (Limited Copy, Cut, Paste)
  • Safari 5 (Mac) (Limited Copy, Cut, Paste)

CommonSpot 8.0 SP2 (Summer 2012) Technical Requirements are available here: Web Content Management Solution – CMS – WCM – ColdFusion CMSTech Specs.